Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 04, 2025 - 11:00 UTC
Scheduled
eero is conducting scheduled maintenance, during which some functionality may be temporarily unavailable. Network connectivity, mesh performance and network setups will not be impacted during this time.
Posted Jul 03, 2025 - 16:42 UTC
This scheduled maintenance affected: eero Mobile Apps and eero Insight.